
Demonstrate Knowledge of Working with 
Selections and Measurement (Domain 4.1) 

 
 
 
  
 As you learned in Domain 3, you can use a variety of selection tools to select one section or 
multiple sections of your image.  You can use a single tool to make a selection or combine techniques from 
a combination of tools to add to or refine your selection. 
 Once you have determined the best selection tool, or tools, for your task and you have made your 
selection, you can used the Edit in Quick Mask Mode button in the Tools panel to clean up your selection.  
The area outside the selection is shown with a red overlay.  While in Quick Mask Mode, you can then 
refine your selection using the Brush tool to subtract pixels from the selection and using the Eraser tool to 
add pixels to the selection.  When you turn off Quick Mask Mode, the selection is shown with the marching 
ants border.  Marching ants is the term using for an active selection. 
 
 There are four selection commands found on the Select menu: 

• All – Selects everything on the active layer 
• Deselect – Removes the selection 
• Reselect – Reactivates the previous selection 
• Inverse – Reverses the selection to the opposite of what is currently selected 

 

TIP: A selection is called marching ants because the dotted lines that are formed around the 
selection appear to be moving! 
 
Copying and Cutting a Selection 
 
 You can cut, copy, or paste a selection.  As in other applications, the Cut command removes the 
selection and places it on the clipboard, allowing you to paste it in Photoshop or in another application.  
The Copy command places the image on the clipboard while leaving the selection in place.  You can past 
the image on the clipboard to duplicate it or to move it to another layer.  
 
 Copy and Paste Commands 

• Copy - Makes a copy to the clipboard of the selection on the active layer 
• Copy Merged - Creates a merged copy of the selection using all visible layers 
• Paste – Places what is on the clipboard to the active layer; if there already is a selection on the 

active layer, the item is pasted into the selection 
• Paste In Place – For selections copies to the clipboard from another document, places the item 

in the approximate same position as it appeared in the original document 
• Paste Into – Places the item on the clipboard inside a selection; a new layer is created with a 

mask of the selection 
• Paste Outside – Places the item on the clipboard outside a selection; a new layer is created 

with a mask of the selection 
 
Working with Selections 
 
 When you are working with a complicated selection, it is a good idea to save the selection in case 
you need to use it again.  To save a selection, click Select on the Application Bar (Win) and then click Save 
Selection.  In the Save Selection dialog box, you can name the selection, save the selection in the current 
document or in a new document, and add the current selection to a previously saved selection, known as a 



channel.  You can access, or load, a saved selection after you save, close, and reopen a Photoshop 
document, which is extremely useful.  To load a selection, click Select on the Application Bar (Win) and 
then click Load Selection, then click OK in the Load Selection dialog box. 
 The refine edge option uses truer edge technology to improve selections.  You can open the Refine 
Edge dialog box on the options bar when any Selection tool is active, or click the Refine Edge command on 
the Select menu.  You can select a variety of views to help you see the quality of your selection and refine 
it.  You can select Edge Detection options, such as selecting the Smart Radius check box, to fine-tune a 
selection that may be very difficult to select, such as hair and leaves on plants.  In the Output To pup-up 
menu, you can designate where the selection will be posted: on a new layer, as a layer mask, a 
combination of a new layer and layer mask, or even in a new document. 
 
Modifying Selections 
 
 You can modify a selection in ways that improve or enhance the selection.  A common problem 
when making a selection is an edge halo.  An edge halo, also called fringing or matting, are the fringe pixels 
in the background that are difficult to isolate and remove.  To help eliminate an edge halo, you can 
contract the selection, which reduces the size of the selection by a set number of pixels.  To contract a 
selection, click Select on the Application Bar (Win), point to Modify, and then click Contract, or in the 
Refine Edge dialog box, drag the Contrast slider.  Other options in the Refine Edge dialog box are Expand, 
which moves the selection outward by the designated number of pixels, and Shift Edge, which expands the 
selection based on a percentage.  The Shift Edge option is only available in the Refine Edge dialog box. 
 

TIP: To cycle through view modes in the Refine Edge dialog box, press F. 
 
TIP: Using a slider in the Refine Edge dialog box allows you to preview changes to the selection; 
clicking a command on the Select menu does not, although you can easily undo your changes. 
 
 You can also remove an edge halo by adjusting the Border Selection.  The Border command is only 
available when you click Select on the Application Bar (Win) and then point to Modify.  Using the border 
option changes the selection from selecting the entire area within a border to selecting only the pixels on 
the border that surround the selection.  You select the width of the selection in the Border Selection dialog 
box.   
 The Color Range command, located on the Select menu, opens the Color Range text box, where 
you can make a selection based on a color or range of color.  Using the various eyedroppers, you can select 
a beginning color and then add to or subtract from the selection.  You can select the Localized Color 
Clusters check box to extend the selection to adjacent pixels.  The Fuzziness slider reduces or expands the 
selected color range.  When the Localized Color Clusters check box is selected, you can use the Range 
slider to adjust the distance from the selected color that similar colors must be do be included in the 
selection.  The Selection Preview pop-up menu allows you to preview the selection with a Black or White 
Matt, in Grayscale or as a Quick Mask. 
 
Touch-Up Brushes 
 
 The retouching tools include a set of brushes that remove imperfections in images.  (Note:  You 
learned about these tools in Domain 3.)  You can use the Spot Healing Brush tool to remove small 
problems in images such as scratches, dust, and other blemishes.  Adjust the brush size to best fit the 
problem you are correcting.  When you click an area with a flaw, Photoshop compares the surrounding 
pixels and corrects the area you clicked based on the other pixels.  You can select the type of repair on the 
options bar. 



• Proximity match – Pixels near the selected problem area are randomly selected and used as a 
patch. 

• Create texture – Pixels in the selected problem area are used to create new texture. 
• Content-aware – The default option, the content of nearby pixels is analyzed and used to 

replace the selected problem area. 
 
 As you learned in Domain 3, the Healing Brush tool is similar to the Spot Healing Brush tool, and 
both tools sample areas used to repair a problem area in an image.  However, the Healing Brush tool 
requires you to first sample the image so that Photoshop can use those pixels to fix the problem area.  
 

TIP: The Smooth command smooths a selection’s edges, but can result in the loss of detail. 
 
Undoing a Selection 
 
 Remember that you can undo an action by clicking the Undo command on the Edit menu.  If you 
need to undo more than just the last action, click the Step Backward command to continue stepping back 
through your actions. 
 The History panel allows you to view the exact commands that you have executed and step back 
several steps at one time.  By default, Photoshop saves up to 20 steps to the point when you first opened 
or saved the document.  To increase the number of steps to be saved, open the Preferences dialog box by 
point to Preferences on the Edit menu, click the Performance category, and then select a number in the 
History States text box up to 1,000.  The History panel also allows you to create a new document from the 
current state, or take a snapshot of a current state.  Creating a new document from the current state is a 
quick way to save a copy of your changes as a reference.  It is important to realize that history states in the 
History panel are deleted when you close the document; they are not available when you reopen the 
document.  You can create snapshots to keep copies of your work during the editing process.  A snapshot 
is created and stored in the current document.  The History brush uses snapshots to paint your image back 
to a previous state.  (Note:  The Art History brush is similar to the History brush, but also applies to stylized 
effects.) 
 

TIP: To return your image to the same condition when it was last saved, click the Revert command 
on the File menu. 
 
Taking Measurements 
 
 To measure areas of an image, such as an image used in health care, radiology, medical research, 
or any other scientific research, you can use tools and commands available on the Analysis menu.  You can 
use the Ruler tool to draw a measured line on the image.  The Measurements Log panel opens allowing 
you to record measurements from the placed rulers.  Measurements can also be taken with any selection 
created by a Selection tool.  If the measurement is taken with either the Rectangular tool or the Elliptical 
Marquee took, the area, length, width, and density are also recorded. 
 
Compositing Images 
 
 Compositing an image combines multiple images into a single image.  This is often done by taking 
different elements from various images and laying them out to create an entirely new image.  Other uses 
for compositing images is to create a single panoramic image from multiple images, or to combine multiple 
images of the same subject into one image that brings the best elements from each individual element, 



color balance, sharpness.  For example, you could combine different shots of the same image to get the 
best picture of each individual or distinct element. 
 When creating a collage of images, where you want to blend one image into another, you can use 
feathering to blur the edge of the selection.  You can adjust feathering settings on the options bar when a 
selection tool is active.  Usually it is best to enter the value before selecting an area or drawing on the 
canvas.  To apply feathering after drawing a selection, click Select on the Application bar, point to Modify, 
click Feather, and then type the number of pixels you want to feather in the Feather Radius text box.  You 
can also open the Refine Edge dialog box and adjust the Feather slider.  The feathered effect is created 
when you create a vector mask from the selection, or by inversing your selection and then pressing Delete.  
You can also use anti-aliasing to smooth the edges between multiple images.  Anti-aliasing softens the 
color of the pixels instead of blurring them.  This option is available also on the options bar when a 
selection tool is active.   
 The Photomerge command combines multiple images into a single image by using a stitching 
effect to create a panoramic image.  It is important that the pictures have overlapping regions to 
Photoshop can stitch the images together.   
 When you combine multiple shots of the same, image, it is important to have the same image 
taken from the same angle and the same distance.  In Photoshop, copy each image in its own layer, then, 
with at least two layers selected, click the Auto-Align Layers command on the Edit menu.  It is 
recommended to also use the Auto-Blend layers command on the Edit menu, which blends the collage, 
panoramic, or multiple exposure images by creating an extended depth of field. 
 
Batch Processing 
 
 If you have many images to which you would like to apply the same techniques, you can use batch 
processing to repeat repetitive actions automatically.  Photoshop has a library of actions available in the 
Actions panel, including image effects, creating frames for your image, and text effects.  You can also 
record and save custom actions in the Actions panel. 
 If you want to repeat certain actions using multiple images, you can turn an action into a droplet.  
A droplet is a stand-alone action saved outside of Photoshop, such as on your desktop.  To execute actions 
in a droplet, drop one or more closed Photoshop files or a folder on the droplet. 
 

TIP: Photoshop does not need to be open to execute a droplet! 
 

Step-by-Step 4.1 
 

1.  Start Photoshop CS5. 
2. Click File on the Application bar, click Open, select the location of your data 

files, click bird and then click Open. 
3. Click File on the application bar, click Save As, and then name the file bird 

selection.   Save this in your Domain 4 folder. 
4. Click View on the Application bar, and then click Rulers to turn on the rulers, 

if necessary. 
5. In the Tools panel, click the Quick Selection tool, and then drag the brush on 

the bird to select it.  Notice that not all of the bird’s legs and feet are 
selected.   

6. Click Select on the Application bar, and then click Edit in Quick Mask Mode.  
The area not selected appears with a red overlay. 



7. In the Tools panel, click the Zoom tool, and then click the bird’s legs to zoom 
in on them. 

8. In the Tools panel, click the Eraser tool, and then erase the masked area on 
the bird’s legs and feet, so the legs are added to the selection. 

9. In the Tools panel, click the Brush tool, on the options bar, select a hard 
round brush, and then paint over the areas around the bird to improve the 
selection of the bird.  The quick mask reappears as you paint.  

10. Click Select on the Application bar, and then click Edit in Quick Mask Mode 
to exit Quick Mask Mode.  The bird is selected with a marching ants border. 

11. Click View on the Application bar, click Fit on Screen. 
12. Click Select on the Application bar, click Save Selection, then in the Save 

Selection diaglog box, in the Name text box, type bird, and then click OK. 
13. Click Select on the Application bar and then click Refine Edge.  The Refine 

Edge dialog box opens. 
14. In the Refine Edge dialog box, click the View pop-up menu, click On Black (B), 

and then press Esc to close the pop-up menu.  Notice that and that there is 
an edge halo around the bird and that there are edges that are not smooth. 

15. In the Refine Edge dialog box, drag the Shift Edge slider left to contract the 
selection, experimenting with the slider until the edges of the bird appear 
smoother.  (Note:  Be sure the Refine Edge dialog box is moved to the side so 
you can preview your image while you work.) 

16. Drag the Smooth slider to the right to soften the edge of the bird, click OK. 
17. On the layers panel, click the Add layer mask button to create a mask of the 

selection.  Just the bird is visible against a transparent background. 
18. Click Save and close the document. 

 
 

Marching Ants!! 


